Minimum Requirements
 
One goal I always had with DokuWiki is that it is simple to setup on basically anything that runs PHP. That includes your personal NAS, an USB stick or a very cheap web host.

As a result, DokuWiki is trying to keep the minimum requirements very low. It does not require any fancy extensions or complicated setup. 

However there's one hard requirement: the minimum PHP version. Today I increased it from the previous 5.3 to 5.6. This of course does not affect the current stable release "Frusterick Manners" but it will be the requirement for the next release.

Now would be a good time to check what PHP version you are currently running. To do so, simply login as superuser into your wiki and add ?do=check the URL. Eg. http://example.com/dokuwiki/doku.php?do=check

If you're running anything under 5.6 think about an upgrade strategy. Even if you're on 5.6, consider moving to 7.x soon.

The above graphic explains why. There is no support, no bugfixes and no security fixes coming out for PHP <5.6 anymore. You're essentially sitting on a ticking time bomb there. 5.6 will at least receive security updates til end of 2018.

TL;DR: the next DokuWiki release will require PHP 5.6 or higher